Increased API latency

Incident Report for SheerID

Resolved

This incident has been resolved.
Posted Jul 09, 2024 - 21:52 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Jul 09, 2024 - 21:38 UTC

Identified

The issue has been identified and a fix is being implemented.
Posted Jul 09, 2024 - 21:10 UTC

Investigating

We are investigating reports of increased API latency and will provide updates as we resolve the issue.

Some customers may notice delays when submitting verification requests.
Posted Jul 09, 2024 - 21:08 UTC
This incident affected: Web services (API).