Increased verification latency

Incident Report for SheerID

Resolved

This incident has been resolved.
Posted Jul 18, 2025 - 00:11 UTC

Investigating

We are investigating reports of increased verification latency across multiple program types.

Some customers may notice delays when submitting verification requests.

All other platform features and functions remain operational.
Posted Jul 17, 2025 - 20:08 UTC
This incident affected: Student programs, Military programs, First Responder programs, Faculty programs, and Medical programs.