Service disruption: increased verification latency and reporting issues

Incident Report for SheerID

Resolved

This incident has been resolved. All SheerID features and services have returned to normal functionality.
Posted Jun 13, 2025 - 15:53 UTC

Investigating

A service provider is experiencing outages that may impact SheerID verification latency, reporting within MySheerID, and potentially other services.

This incident is being closely monitored for resolution.
Posted Jun 12, 2025 - 19:20 UTC
This incident affected: Web services (API, MySheerID) and Reporting, Student programs, Military programs, First Responder programs, Faculty programs, Medical programs.