Military Data Source is down
Incident Report for SheerID
Resolved
This incident has been resolved.
Posted Sep 27, 2024 - 22:13 UTC
Update
A data source supporting Military programs is experiencing issues. All other services, including our document review service and other data providers, will be performing as expected.
Posted Sep 27, 2024 - 17:02 UTC
Investigating
We are currently investigating this issue.
Posted Sep 27, 2024 - 16:48 UTC
This incident affected: Military programs.