MySheerID Reporting Down

Incident Report for SheerID

Resolved

This incident has been resolved. We suggest re-running any reports you had stuck in pending
Posted Sep 16, 2025 - 19:43 UTC

Investigating

Reports of MySheerID reporting getting stuck in pending status. Our engineering team is investigating this issue currently.
Posted Sep 15, 2025 - 17:34 UTC
This incident affected: Reporting.