Latency and Timeouts in API endpoints

Incident Report for SheerID

Resolved

This incident has been resolved.
Posted Aug 28, 2026 - 16:41 UTC

Investigating

We're investigating heightened latency and timeouts in some API endpoints, including getVerificationDetails.
Posted Aug 28, 2026 - 16:00 UTC
This incident affected: Web services (API, MySheerID).